search menu icon-carat-right cmu-wordmark

CERT Coordination Center


TP-Link EAP Controller lacks RMI authentication and is vulnerable to deserialization attacks

Vulnerability Note VU#581311

Original Release Date: 2018-09-26 | Last Revised: 2018-11-08

Overview

The TP-LINK EAP Controller is TP-LINK's software for remotely controlling wireless access point devices. EAP Controller for Linux lacks user authentication for RMI service commands, as well as utilizes an outdated vulnerable version of Apache commons-collections, which may allow an attacker to implement deserialization attacks and control the EAP Controller server.

Description

CWE-306: Missing Authentication for Critical Function - CVE-2018-5393

EAP Controller for Linux utilizes a Java remote method invocation (RMI) service for remote control. The RMI interface does not require any authentication before use. Remote attackers can implement deserialization attacks through the RMI protocol. Successful attacks may allow a remote attacker to remotely control the target server and execute Java functions or bytecode.

CWE-502: Deserialization of Untrusted Data - CVE-2015-6420

EAP Controller for Linux bundles a vulnerable version of Apache commons-collections v3.2.1 with the software, which appears to be the root cause of the vulnerability. Therefore, EAP Controller v2.5.3 and earlier are vulnerable to CVE-2015-6420 as documented in VU#576313.

EAP Controller v2.5.3 and earlier for Linux are affected by both vulnerabilities.

Impact

A Java application or library with the Apache Commons Collections library in its classpath may be coerced into executing arbitrary Java functions or bytecode.

Solution

The Omada Controller software v3.0.2 and later are not affected by this issue. Software download is available on the TP-Link support website. If older software must be used, users can help mitigate and reduce risk by updating the vulnerable libraries does not necessarily eliminate the vulnerability in all scenarios, as described in As described in VU#576313.

Update Apache commons-collections

Affected users should update the system Apache commons-collections library to at least version 3.2.2 or 4.1. For details, please see VU#576313.

Update the JRE version of EAP

Affected users should also update the Java Runtime Environment (JRE) used by EAP to the latest available version. Recent versions of JRE have improved deserialization protection features.

Vendor Information

581311
Expand all

TP-LINK

Notified:  July 03, 2018 Updated:  October 16, 2018

Status

  Affected

Vendor Statement

No statement is currently available from the vendor regarding this vulnerability.

Vendor Information

We are not aware of further vendor information regarding this vulnerability.

Addendum

There are no additional comments at this time.

If you have feedback, comments, or additional information about this vulnerability, please send us email.


CVSS Metrics

Group Score Vector
Base 7.5 AV:N/AC:L/Au:N/C:P/I:P/A:P
Temporal 5.9 E:POC/RL:OF/RC:C
Environmental 5.9 CDP:ND/TD:ND/CR:ND/IR:ND/AR:ND

References

Credit

Thanks to Liu Zhu,of Huawei Weiran Lab for reporting this vulnerability.

This document was written by Garret Wassermann.

Other Information

CVE IDs: CVE-2018-5393, CVE-2015-6420
Date Public: 2018-09-18
Date First Published: 2018-09-26
Date Last Updated: 2018-11-08 18:58 UTC
Document Revision: 102

Sponsored by the Department of Homeland Security Office of Cybersecurity and Communications.